Opened 14 years ago

Closed 14 years ago

#402 closed defect (invalid)

Demo's not working with IE 5.5 kitchen sink 0.2.2

Reported by: anonymous Owned by: anonymous
Priority: high Milestone:
Component: BuildTools Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

I was testing the demos in the 0.2.2 distribution with a standalone IE 5.5 browser (from evolt.org). All 4 demo's had rendering issues.

Change History (4)

comment:1 Changed 14 years ago by anonymous

Type: defectenhancement

It doesn't seem to be only the demos. Just including the dojo.js that comes with dojo-0.2.2-kitchen_sink in a web page and IE seems stuck loading it forever. I had no problems with dojo-0.2.2-ajax.

comment:2 Changed 14 years ago by anonymous

Type: enhancementdefect

comment:3 Changed 14 years ago by anonymous

Component: GeneralBuildTools

I have tried to find out what was causing the problem. AFAIK the script seems to be working fine until it reaches this line

dojo.storage.provider.writeStorage();

in dojo.js.uncompressed.js around line 9959. I found this out by removing most of the script and re-adding the removed parts until it reproduced the defect.

Unfortunately I have not enough knowledge of the framework to attempt a fix.

comment:4 Changed 14 years ago by alex

Resolution: invalid
Status: newclosed

The dojo.storage.* namespace in 0.2.2 requires both the src/ directory to be present and Flash 8 to function correctly. I'm not sure that this is a bug so much as it is a misconfiguration and an over-inclusive profile for kitchen-sink (although I'm not sure what we'd call it instead).

Note: See TracTickets for help on using tickets.