Opened 12 years ago

Closed 12 years ago

#4019 closed defect (fixed)

TabContainer: non-layout tabs don't look like tabs at all

Reported by: bill Owned by: Adam Peller
Priority: high Milestone: 0.9
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Should probably just get rid of non-layout tabs. See test in test_LayoutCode.html for "Tab Non-Layout". Doesn't look like tabs at all.

Change History (4)

comment:1 Changed 12 years ago by bill

Owner: changed from bill to Adam Peller

comment:2 Changed 12 years ago by Adam Peller

What does this mean? Just get rid of that part of the test? Or are you suggesting that the TabContainer? code needs to change also? (get rid of doLayout?)

comment:3 Changed 12 years ago by bill

I guess practically speaking it just means to get rid of the test.

I *want* to get rid of the doLayout feature from TabContainer? altogether. The problem is that the feature is defined in StackContainer? and I assume we still want StackContainer? to have that option, so I'm not sure how to denote that doLayout=false is supported in StackContainer? but not in TabContainer? (and AccordionContainer? too, by the way).

Or maybe there should be StackContainer? and LayoutStackContainer?, only the latter doing sizing of it's children. Not sure. We can talk online.

comment:4 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [10084]) Remove non-layout from test to de-support for 0.9. Fixes #4019. Address long-term issue of doLayout property in 1.0 - see #3450

Note: See TracTickets for help on using tickets.