Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3999 closed defect (fixed)

InlineEditBox: textarea edit size too narrow (IE6)

Reported by: bill Owned by: haysmark
Priority: high Milestone: 0.9
Component: Dijit Version: 0.9
Keywords: Cc: itorrey
Blocked By: Blocking:

Description

On IE6, load test_InlineEditBox.html, and without resizing the browser window click the first textarea. Width is too narrow. Also a horizontal scrollbar shows up on the bottom, presumably due to the width problem.

Also noticing problems where suddenly the width gets really short after typing a bunch of text with no spaces but can't reproduce it reliably.

Change History (3)

comment:1 Changed 12 years ago by haysmark

Cc: itorrey added

So I figured out why the width is too narrow: .tundra .dijitTextArea, which sets the fieldset width of the TextArea? to 50%, and sure enough that's exactly what IE6 is doing. As soon as you remove that line it works as intended. It's a wonder that the other browsers aren't doing the same thing.

Tundra shouldn't touch the width of TextArea?. Should this go to itorrey?

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [9983]) Remove strange width:50% applied to textareas. Fixes #3999.

comment:3 Changed 12 years ago by bill

(In [10100]) Remove strange width:50% applied to textareas. Refs #3999.

Note: See TracTickets for help on using tickets.