Opened 12 years ago

Closed 12 years ago

#3997 closed defect (fixed)

InlineEditBox in themeTester.html: can't edit (IE6)

Reported by: bill Owned by: haysmark
Priority: high Milestone: 0.9
Component: Dijit Version: 0.9
Keywords: Cc: brunet@…
Blocked By: Blocking:

Description

Clicking the InlineEditBox? for a textarea on IE6 works, but in themeTester.html there's no effect. Something weird w/the focus.js code, perhaps?

Attachments (1)

3997.patch (870 bytes) - added by haysmark 12 years ago.
Proposed fix

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by ptbrunet

Is the following the same problem? Using http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_InlineEditBox.html click on (or press enter if you tab to it) the second textarea widget (the second one that starts with "I'm one big paragraph..." The box opens for a few ms and then immediately closes. This is only on IE.

comment:2 Changed 12 years ago by ptbrunet

Cc: brunet@… added

comment:3 Changed 12 years ago by haysmark

I can't even load themeTester in IE.

comment:4 Changed 12 years ago by haysmark

This seems related to the use of onactivate in focus manager. Why does focus manager listen to onactivate? What happens in themeTester is the onactivate bubbles up to the div surrounding the InlineEditBox? (not even part of the widget) and the body listener fires again, blurring focus from the InlineEditBox? and causing it to close in the same thread that opened it. It seems to work as intended if you change onactivate/deactivate to onfocus/blur.

Changed 12 years ago by haysmark

Attachment: 3997.patch added

Proposed fix

comment:5 Changed 12 years ago by bill

onactivate/ondeactivate are use on-purpose. The purpose of focus manager is to trace whenever any element on the page gets focus/blur, which means that the focus event has to bubble up from the element to the <body> tag... but on IE focus and blur don't bubble up.

comment:6 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [10051]) Fixes #3997. Proxy commit for haysmark. Move the focus until after the edit widget is visible.

Note: See TracTickets for help on using tickets.