Opened 12 years ago

Closed 12 years ago

#3954 closed defect (invalid)

Widget startup function is not called when created programmatically using new

Reported by: guest Owned by: bill
Priority: high Milestone:
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

When creating a widget programmatically using the new syntax

    var grid = new judo.widget.Grid({id: "MyGrid", ...})

the startup function of the widget is not executed.

This could be tricky because during load, you want to wait to call widget's startup till all widgets are created, but if we don't call it when using new syntax, any additional setup done in this function is skipped.

Change History (1)

comment:1 Changed 12 years ago by bill

Resolution: invalid
Status: newclosed

Right, you have to call startup manually, by design, after all the other widgets (including child widgets of this widget) have been created and added to the widget.

Note: See TracTickets for help on using tickets.