Opened 12 years ago

Closed 12 years ago

#3950 closed defect (fixed)

BIDI Tree in high contrast mode - expando is in wrong place

Reported by: Adam Peller Owned by: Adam Peller
Priority: high Milestone: 1.0
Component: Accessibility Version: 0.9
Keywords: bidi Cc: yinjun@…
Blocked By: Blocking:

Description (last modified by Adam Peller)

In RTL, the indentation is correct, but the expando chars appear on the wrong side of the screen

Change History (4)

comment:1 in reply to:  description Changed 12 years ago by Sam Foster

Cc: Becky Gibson added
Description: modified (diff)

Replying to peller:

In LTR, the tree nodes expand, but to not indent. In RTL, the indentation is correct, but the expando chars appear on the wrong side of the screen

comment:2 Changed 12 years ago by Adam Peller

Description: modified (diff)
Keywords: bidi added
Summary: Tree in high contrast mode - indentations are wrongBIDI Tree in high contrast mode - expando is in wrong place

Yup, LTR mode looks fine now. Not sure what regressed or where it got fixed.

RTL is the problem now. To reproduce, you just need a dir="rtl" on the body, or you can append ?test-bidi to the test_Tree.html URL.

Unless you've got a quick fix, since this is now a bidi+hc bug, I'm ok with putting this off to 1.0, if necessary.

comment:3 Changed 12 years ago by Adam Peller

Cc: yinjun@… added; Becky Gibson removed
Milestone: 0.91.0
Owner: changed from Becky Gibson to Adam Peller

I'll hold on to this, for now. Perhaps Justin can look at it. Justin, to simulate high contrast mode, I usually just go in DOM inspector and set dijit_a11y as a class on the BODY tag.

comment:4 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [9990]) Fixes #3950

Note: See TracTickets for help on using tickets.