Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3917 closed defect (fixed)

lfx.slideIn/slideOut -- misleading names

Reported by: tk Owned by: Adam Peller
Priority: high Milestone: 0.9
Component: fx Version: 0.9
Keywords: slideIn slideOut fx Cc: Bryan Forbes, alex
Blocked By: Blocking:

Description

Poorly named? I was looking at creating some test pages for a friend to help demonstrate equivilent coding from prototype->dojo and come to find that slideIn/Out now are wipes...

Slide implies that the item moves... much like the old slideTo() function moved an element from current position to point A... but with slideOut/In the element dissappeared as it slid away (ie, it was sliding under another element or something)

Are there plans of reimplementing these or atleast clarifying the slideX names in use now?

assigning to peller since I see his checkin renamed the functions, I just couldnt find anything on why the rename happened.

Change History (6)

comment:1 Changed 12 years ago by tk

Summary: lfx.slideIn/slideOutlfx.slideIn/slideOut -- misleading names

comment:2 Changed 12 years ago by Adam Peller

Cc: Bryan Forbes alex added; tk removed
Milestone: 0.9

Bryan, Alex, can you comment?

comment:3 Changed 12 years ago by bill

There are two similar animations that go from a hidden state to a displayed state as the element changes height.

One uncovers the text from top to bottom like pulling a sheet off of a painting. The painting doesn't move but it's slowly unhidden. You see the top of the painting first and the bottom is shown last.

The other is like having the painting on a roll-up window shade, and pulling down the shade. The painting is actually moving. You see the bottom of the painting first and then it slides down.

I think we implemented the first one which is called wipe-in but called it slide-in? That's my understanding anyway... so I agree the names should change (but don't have a strong opinion)

comment:4 Changed 12 years ago by tk

Bill,

You are right... there used to be WipeIn/Out? and SlideIn/Out?... 1 set was lost and then we renamed the Wipes to Slide for some reason...

I would say the original names were very good IMO. (WipeIn/Out? and SlideIn/Out? (as seperate animations of course, how you described 1 handles each case))

comment:5 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [9999]) Rename slideIn/slideOut to wipeIn/wipeOut. Fixes #3917

comment:6 Changed 12 years ago by Adam Peller

(In [10000]) Rename slideIn/slideOut to wipeIn/wipeOut. Refs #3917

Note: See TracTickets for help on using tickets.