Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3899 closed defect (fixed)

Regression in [9822]: can't edit autoSave InlineEditBox

Reported by: haysmark Owned by: bill
Priority: blocker Milestone: 0.9
Component: Dijit Version: 0.9
Keywords: Cc: brunet@…
Blocked By: Blocking:

Description

The most consistent way to reproduce this issue is to enable autoSave for the TextArea? in test_InlineEditBox. When you click to open the TextArea?, you should at least be able to see the TextArea? (editing it is another matter of course; see #3752). As of [9822], an autoSaving TextArea? does not even open in FF and IE. It does open in [9821]. It definitely appears to be a focus issue.

Since hiding the Enter key from the listening widgets will enable autoSave to work for TextArea?, we should try to get this aspect of autoSave working again for TextArea?.

Change History (4)

comment:1 Changed 12 years ago by bill

(In [9865]) InlineEditBox? momentarily remove focus from anything, because it hides the display-text before focus is transfered to the edit widget. Don't take that as a signal that the widget has lost focus. Refs #3899

(fixed for IE, but there's still a FF issue where it doesn't realize that the TextArea? got focus, because it's an iframe)

comment:2 Changed 12 years ago by ptbrunet

Cc: brunet@… added

comment:3 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [9896]) Refactor the focus code, adding better support for embedded iframes, fixing problem on FF where clicking an InlineEditBox? for a TextArea? opens but then immediately closes. Fixes #3899.

comment:4 Changed 12 years ago by bill

(In [9934]) Remove overzealous optimization that was causing onTouchNode() to ignore calls from onFocusNode(), thus not resetting the stack of active widgets (and calling _onBlur/_onFocus) when tabbing between widgets.

Refs #3899

Note: See TracTickets for help on using tickets.