Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#3888 closed defect (invalid)

[cla][patch] open must be called

Reported by: guest Owned by: haysmark
Priority: low Milestone: 0.9
Component: Dijit Version: 0.9
Keywords: ComboBox Cc: nicola.rizzo+dojo@…
Blocked By: Blocking:

Description

The open method now must be called after an explicit makePopup(), but in dijit.form._DropDownTextBox the open function already contains a makePopup() call.
Nicola

Attachments (1)

ComboBox.diff (632 bytes) - added by guest 12 years ago.
nicola.rizzo+dojo@…

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by guest

Attachment: ComboBox.diff added

nicola.rizzo+dojo@…

comment:1 in reply to:  description Changed 12 years ago by guest

Replying to guest:

The open method now must be called after an explicit makePopup(), but in dijit.form._DropDownTextBox the open function already contains a makePopup() call.
Nicola

title: "open() must be called after a makePopup()"

comment:2 Changed 12 years ago by bill

Owner: changed from bill to haysmark

I don't understand this bug. What's the actual problem that occurs?

comment:3 in reply to:  2 Changed 12 years ago by guest

Replying to bill:

I don't understand this bug. What's the actual problem that occurs?

It isn't really a bug: after the creation of a ComboBox?, I can't call the open() method, because _popupWidget doesn't exists.
I call directly a _startSearch(): is there a way to show a result list calling a public function?
Thank you[[BR]]

Nicola

comment:4 Changed 12 years ago by bill

Resolution: invalid
Status: newclosed

Oh, there's no API for that. Everything has to be through dojo.data and through keyboard interaction. That's by design; don't want to provide more API functions than we have to.

Note: See TracTickets for help on using tickets.