Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#3868 closed defect (fixed)

drop down button arrow does not display properly within toolbar in IE7

Reported by: Becky Gibson Owned by: Sam Foster
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc: bill, dante
Blocked By: Blocking:

Description

When a drop down button with the showLabel parameter set to false is placed in a toolbar, the arrow is not visible. In Firefox the toolbar height seems to automagically adjust to include the arrow but in IE 7 it does not and the arrow is clipped. In IE 6 the arrow is partially clipped. The arrow displays fully in Firefox 2.

Attachments (1)

toolbarHCIE7.jpg (16.5 KB) - added by Becky Gibson 12 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by Becky Gibson

Not being a CSS whiz I could use some help on this one!

comment:2 Changed 12 years ago by bill

To be honest I'm starting to have doubts about that arrow being there at all. I like the way it looks for normal buttons (with text) but for toolbar buttons (with or without text), it seems like the designer might not want it shown.

comment:3 Changed 12 years ago by Sam Foster

I cant reproduce this (now) - looks fine in IE7, IE6 (regular contrast mode). Can you confirm and (hopefully) close this? If not, feel free to assign to me.

comment:4 Changed 12 years ago by Becky Gibson

Owner: changed from Becky Gibson to dante

The arrow is now properly displayed in IE7 in standard mode but does not show at all in high contrast mode. I have attached a screen shot of IE 7 in high contrast mode. The Login and background and foreground buttons should have an arrow displayed. Although we might want to check with Bill whether we want the arrow or not in any mode.

Changed 12 years ago by Becky Gibson

Attachment: toolbarHCIE7.jpg added

comment:5 Changed 12 years ago by bill

Indeed I struggled over whether DropDownButton? should display an arrow or not. IE displays an error (see the mail icon on the IE6 toolbar, or the Page or Tools button on the IE7 toolbar), so I think it makes sense. Obviously it could be there or not depending on the theme...

comment:6 Changed 12 years ago by bill

Oops, I meant "arrow" not "error"!

comment:7 Changed 12 years ago by dante

Cc: Sam Foster bill added
Milestone: 0.91.0
Status: newassigned

couple of notes: a) becky said she didn't mean to assign this to me, so anyone feel free to take it? b) there seems to be some discussion about what needs to happen still going on, so punting this until "after today"

comment:8 Changed 12 years ago by dante

Cc: dante added; Sam Foster removed
Owner: changed from dante to Sam Foster
Status: assignednew

comment:9 Changed 12 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

someone reworked the buttons style - works now so closing.

comment:10 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.