Opened 12 years ago

Closed 12 years ago

#3861 closed defect (fixed)

undo/back: exception in loadIframeHistory() if d.back.init() hasn't previously been called

Reported by: Robert Coup Owned by: Robert Coup
Priority: high Milestone:
Component: General Version: 0.9
Keywords: undo Cc: Ben Lowery
Blocked By: Blocking:

Description

dojo.back.init() needs to be called from a <script> tag inside the <body> tag. It then writes out the <iframe> to attempt to load the history file.

If it's not called then loadIframeHistory() throws a non-obvious exception when addToHistory(),etc is called. IMO it should be replaced with a console warning explaining what the problem is and how to fix it, then ignore the error. Note that loading a non-existant history file throws no errors, it just happily does nothing.

blowery: I'll check a fix in tomorrow unless you have any comments.

Change History (1)

comment:1 Changed 12 years ago by Robert Coup

Resolution: fixed
Status: newclosed

(In [9848]) Add a warning instead of throwing an obscure exception if dojo.back.init() hasn't been called. Fixes #3861.

Note: See TracTickets for help on using tickets.