Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#3858 closed defect (fixed)

ComboBox with option tag list has wrong value on page refresh in FF

Reported by: haysmark Owned by: haysmark
Priority: high Milestone: 0.9
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

If you load test_ComboBox and refresh the page, the first ComboBox? goes blank. This is because it selects the first value (blank) instead of the "selected" value. This is a bug in FF caused by deleting the option tags.

The workaround for now will be to set display:none on the option tags.

Attachments (1)

selectbug.html (480 bytes) - added by haysmark 12 years ago.
Native FF select bug

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by haysmark

Attachment: selectbug.html added

Native FF select bug

comment:1 Changed 12 years ago by haysmark

Status: newassigned

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [9804]) ComboBox? hides its option tags instead of deleting them. Workaround for FF bug. Fixes #3858. Patch from Mark Hays (IBM, CCLA on file)

comment:3 Changed 12 years ago by bill

Note: it's strange that we have to do anything at all with the option tags; seems like they wouldn't display anyway, because we remove srcNodeRef from the DOM tree (and replace it with the template for ComboBox?).

Best hint I can find is in [8674], in the comment if you keep the node, it is visible on the page!, but not sure why. Doesn't seem to be an issue in 0.4 tree.

comment:4 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.