Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#3838 closed defect (fixed)

Rename Textbox to TextBox

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 0.9
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Capitalize Box in all case. Widget names are sometimes *box and sometimes *Box

example: dijit.form.Textbox dijit.form.Checkbox dijit.form.DateTextbox? etc

vs

dijit.form.InlineEditBox? dijit.form.ComboBox? dijit.form._DropDownTextBox


Rationale:

Microsoft .Net: System.Windows.Controls.TextBox? (also ComboBox? and CheckBox?, see http://msdn2.microsoft.com/en-us/library/system.windows.controls.textbox.aspx)

Google web toolkit: com.google.gwt.user.client.ui.TextBox?

--- But rename might be difficult, see http://svn.haxx.se/users/archive-2003-09/0043.shtml Also, case only changes was the cause of some problem with subversion a long time ago; hopefully it's fixed now. I wonder if we've upgraded subversion since then though.

Change History (5)

comment:1 Changed 12 years ago by bill

Owner: changed from bill to Douglas Hays

comment:2 Changed 12 years ago by Douglas Hays

(In [9947]) References #3838. Prepare dijit tree for a case-sensitive rename of 10 files.

comment:3 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [9948]) Fixes #3838. Renamed *box widgets in dijit to *Box

comment:4 Changed 12 years ago by Jared Jurkiewicz

(In [9977]) Adjusting for a widget rename. refs #3838

comment:5 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.