Opened 12 years ago

Closed 12 years ago

#3827 closed defect (fixed)

Dialog animation duration not settable

Reported by: guest Owned by: bill
Priority: high Milestone: 0.9
Component: Dijit Version: 0.9
Keywords: Dialog duration animation Cc:
Blocked By: Blocking:

Description

The duration of the animation cannot be specified from HTML but can be changed if the dialog is created programmatically. I don't know if this is by design, but cannot be only hardcoded.

Change History (4)

comment:1 Changed 12 years ago by guest

More info.

Dojo version: dojo-0.9.0beta

Mail: fermo111@…

comment:2 Changed 12 years ago by bill

Milestone: 1.0

Yes, _duration is an internal property so isn't meant to be set either in markup or programatically. The parser filters out such properties:

if(name.charAt(0)=="_"){ continue; } 	// skip internal properties

Should probably just make it a public variable.

comment:3 Changed 12 years ago by bill

Milestone: 1.00.9
Status: newassigned

comment:4 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [9812]) Make duration a public parameter. Fixes #3827.

Note: See TracTickets for help on using tickets.