Opened 15 years ago

Closed 15 years ago

#3823 closed defect (wontfix) toISOString and fromISOString have uppercase acronyms

Reported by: skinner Owned by: Adam Peller
Priority: high Milestone: 0.9
Component: Date Version: 0.9
Keywords: Cc:
Blocked By: Blocking:


I think that back in 0.4, had ISO functions like "setIso8601" and "fromIso8601". Now in 0.9, has functions named "toISOString" and "fromISOString".

The dojo style guide says, "Abbreviations and acronyms SHOULD NOT be UPPERCASE when used as a name: getInnerHtml(), getXml(), XmlDocument?".

The old function names conformed to the dojo style guide, and the new names don't. Was this an intentional change, or just an oversight?

Change History (4)

comment:1 Changed 15 years ago by Adam Peller

It was done to match the proposed ECMA standard. I'm not crazy about this conflicting with our style guide, and I'm not even able to find a reference to this atm -- perhaps it's shifting around? What do you suggest we do?

comment:2 Changed 15 years ago by Adam Peller

Milestone: 0.9

whatever we do, we should come to a resolution for 0.9

comment:3 Changed 15 years ago by skinner

Got it. I didn't know that the names were chosen to match the proposed standard. A worthy goal. Bummer that it conflicts with the style guide. I have no suggestion for resolving that conflict.

This particular detail of the dojo style guide is maybe out of sync with the cultural norms in the rest of the JavaScript? world, outside of dojo. Personally I like the dojo convention of not using UPPERCASE for acronyms, but it does seem to lead to problems, since using UPPERCASE seems to be what everybody habitually does. If we could go back in time a year, I might reluctantly suggest changing that entry in the style guide, but I think we're now past the time when we could do that.

comment:4 Changed 15 years ago by Adam Peller

Resolution: wontfix
Status: newclosed

well, not having any better ideas myself, I'm marking this wontfix. Please reopen if you have any suggestions.

Note: See TracTickets for help on using tickets.