Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#3808 closed defect (fixed)

CLDR data generator should be fixed by adding code to convert U+200F to "u200F" in nls JS files

Reported by: Adam Peller Owned by: Adam Peller
Priority: high Milestone: 1.3
Component: Internationalization Version: 0.9
Keywords: Cc: hwcdl@…
Blocked By: Blocking:

Description

see dijit/tests/i18n/currency.html

Change History (8)

comment:1 Changed 12 years ago by Adam Peller

Cc: hwcdl@… added

comment:2 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [9784]) Escape U+200F references, fix empty entries. Fixes #3808, Refs #3802

comment:3 Changed 12 years ago by Adam Peller

oops. meant refs #3842

comment:4 Changed 11 years ago by Adam Peller

Milestone: 0.91.3

The problem is turning up in other places, like dates. It turns out, the problem is in Rhino's implementation of eval: https://bugzilla.mozilla.org/show_bug.cgi?id=471005

comment:5 Changed 11 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

comment:6 Changed 11 years ago by Adam Peller

Resolution: fixed
Status: reopenedclosed

Fixed in [16129]

comment:7 Changed 11 years ago by Adam Peller

(In [16322]) Additional patch to correct a Rhino bug with bidi override chars in the build. like dojo.fromJson, dojo.requireLocalization also uses eval on the file contents and must be patched. Fixes #3808 !strict

comment:8 Changed 11 years ago by Adam Peller

(In [16323]) should have hit save first. Include cast to JS String. Refs #3808 !strict

Note: See TracTickets for help on using tickets.