Opened 12 years ago

Closed 12 years ago

#3795 closed defect (fixed)

Regression in [9698]: TextArea InlineEditBox not opening in FF

Reported by: haysmark Owned by: bill
Priority: blocker Milestone: 0.9
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

See [9698]. When you click the paragraph in test_InlineEditBox, the textarea flickers into view and disappears again. The textarea is completely unusable only in FF. Very strange.

Change History (2)

comment:1 Changed 12 years ago by bill

Yup, sorry about that, meant to mention it in the checkin comment. It's this line in Textarea.js:

dijit.util.focus.set(this.iframe.contentWindow);

It seems to be setting focus to the brower's outermost window (or maybe clearing focus from anything?), rather than to the TextArea?'s iframe, thus causing the TextArea? to become defocused, thus causing the InlineEditBox? to hide it (immediately after showing it).

I'll try to fix; may need to talk to Doug about it though.

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [9711]) Fix focus on iframes. Although you focus on iframe.contentWindow, that's useless for tracing parentNode upwards (to the main document)... need to use the iframe itself for that.

Fixes #3795.

Note: See TracTickets for help on using tickets.