Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#3738 closed enhancement (duplicate)

Enhancements and useful methods for dojox.layout.ContentPane

Reported by: guest Owned by: mumme
Priority: high Milestone: 1.0
Component: DojoX Layout Version: 0.9
Keywords: dijit.layout.contentPane executeScripts Cc: irv@…
Blocked By: Blocking:

Description

In our web2.0 application that is currently running on 0.4.3, we make heavy use of the following features of ContentPane?:

executeScripts fixAndSplitPaths bindArgs (tweaking the dojo.io method and content for url parameters)

We have ported our app to use 0.9b, and had to add these two methods. For reference we easily added part of the executeScripts by doing the following:

var node = this.containerNode
this.domNode;

dojo.query( "script", node ).forEach( function( node ){ dojo.eval( dojox.data.dom.textContent( node ) ); } );

Unforutnately the method thing isn't as easy as now there are xhrGet and xhrPost, so we could either do that with an if or else, or we can just call the doIt method directly.... In either case, we need to have access to the ioArgs that are used.

My email is irv@… if you need any more info.

Thanks,

Irv

Change History (5)

comment:1 Changed 12 years ago by tk

Cc: irv@… added
Keywords: dijit.layout.contentPane executeScripts added

Updating with the reports email in the CC field, this way Irv you will be notified of all the discussion/changes that take place on this ticket.

-Karl/tk

comment:2 Changed 12 years ago by bill

Milestone: 1.0
Owner: changed from bill to mumme

Also see #2654 for plans and thoughts on dojox.ContentPane?. Reassigning to Fredrick.

comment:3 Changed 12 years ago by dante

Resolution: duplicate
Status: newclosed

duplicate of #3594

comment:4 Changed 12 years ago by mumme

(In [9803]) Initial checkin of a enhanced ContentPane?, with support for scripts, styles, path adjustments, much like in 0.4, but with some enhancements. Removed the java handler code though (nobody requested it). refs #3594, refs#2852, refs #2040, refs #3217, refs #3738

comment:5 Changed 9 years ago by bill

Component: DijitDojoX Layout
Note: See TracTickets for help on using tickets.