Opened 12 years ago

Closed 12 years ago

#3721 closed defect (fixed)

0.9: base,html.rtl tests fail on IE 6

Reported by: Jared Jurkiewicz Owned by: Adam Peller
Priority: high Milestone: 1.1
Component: HTML Version: 0.9
Keywords: bidi Cc: hwcdl@…
Blocked By: Blocking:

Description

PASSED test: ../../dojo/tests/_base/html_rtl.html::t::coordsWithHorzScrollbar

_AssertFailure: [object Error]: assertEqual() failed: expected |0| but got82|

[object Error] ERROR IN: function eventClientXY(t){ IE only test if(dojo.isIE){ show vertical scrollbar dojo.byId("rect_vert").style.display = ""; var rect = dojo.byId("rect100"); var assertException = null; function rect_onclick(e){ move the rectangle to the mouse point rect.style.left = e.pageX + "px"; rect.style.top = e.pageY + "px"; window.alert("Do NOT move your mouse!!!

" + "The black rectangle's top-left point should be under the mouse point.

" + "If not, you will see a failure in the test report later.

" + "Now press the space bar, but do NOT move your mouse."); rect.fireEvent('ondblclick'); } function rect_ondblclick(){ test if the rectangle is really under the mouse point try{ t.is(0, event.offsetX); t.is(0, event.offsetY); }catch (e){ allow the exception in a event handler go to the event firer assertException = e; } } dojo.connect(rect, "onclick", null, rect_onclick); dojo.connect(rect, "ondblclick", null, rect_ondblclick); window.alert("Move the mouse to anywhere in this page, and then press the space bar."); rect.fireEvent('onclick'); if(assertException != null){ throw assertException; } } }

FAILED test: ../../dojo/tests/_base/html_rtl.html::t::eventClientXY PASSED test: ../../dojo/tests/_base/html_rtl.html

Attachments (1)

TestcaseDojoCoordsBugIE.html (482 bytes) - added by guest 12 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Adam Peller

Owner: changed from Bryan Forbes to Adam Peller

hmm... worked for me

comment:2 Changed 12 years ago by Adam Peller

Resolution: invalid
Status: newclosed

seems to work after retesting

comment:3 Changed 12 years ago by Adam Peller

Keywords: bidi added

comment:4 Changed 12 years ago by dante

Milestone: 0.91.1
Resolution: invalid
Status: closedreopened

this appears when you runTests.html in ie6 or 7 for me, and was reported today on #dojo

Changed 12 years ago by guest

comment:5 Changed 12 years ago by guest

This Bug is caused by the dojo._fixIeBiDiScrollLeft function. The clientWidth is always read by the dojo.doc.documentElement. This returns 0 in IE >=6 if the browser is in Quirksmode. In Quirksmode the body-Element needs to be used. Replacing the de-variable in dojo._fixIeBiDiScrollLeft with following fixes the problem:

var de = ((dojo.doc["compatMode"] == "BackCompat") || (dojo.isIE < 6)) ? dojo.doc.body : dojo.doc.documentElement;

Regards, makin

comment:6 Changed 12 years ago by Adam Peller

Cc: hwcdl@… added

I still see a UT failure with this change.

comment:7 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: reopenedclosed

(In [11955]) Fixes bidi in quirks mode (thanks, makin) Fixes #3721 and backs out change from [11944] Refs #5509. Plus some size reductions. !strict

Note: See TracTickets for help on using tickets.