Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#37 closed defect (wontfix)

setting a property for a widget to false keeps it as a boolean

Reported by: dylan Owned by: [email protected]
Priority: low Milestone:
Component: Widgets Version: 0.1
Keywords: boolean, widget Cc: [email protected]
Blocked By: Blocking:

Description

For a widget, if you set a default value for a property to false, i.e. this.foo = false , the property, when set through properties that are passed through markup or a JS object, is set to true rather than the value passed.

Change History (3)

comment:1 Changed 15 years ago by alex

Resolution: wontfix
Status: newclosed

this is a feature, not a bug

(I've always wanted to say that in a bug report!)

comment:2 Changed 15 years ago by [email protected]

Interesting "feature". I'm not sure that that should be the default behavior if you pass in something other than "true" or "false" considering this is, ya know, JavaScript? and all.

Not a 0.1 stopper in the least. Let's consider reopening after release though.

comment:3 Changed 13 years ago by (none)

Milestone: 0.1beta

Milestone 0.1beta deleted

Note: See TracTickets for help on using tickets.