Opened 12 years ago

Closed 12 years ago

#3637 closed defect (fixed)

Potential Bug With AccordionPane in dojo .4.1 with Regards to Tab Sequence

Reported by: guest Owned by: simonjb
Priority: high Milestone: 0.9beta
Component: Accessibility Version: 0.4.1
Keywords: Cc: jkharness87@…
Blocked By: Blocking:

Description

We noticed that the AccordionPane? (or one of its subwidgets) does not handle tabbing correctly in Firefox 2.0. Specifically, given the following code snippet, the user interface will get ugly when one tabs out of the first text field in the first Pane:

 <span>
        <dojo:AccordionContainer>
            <dojo:ContentPane selected="true" label="Label 1" >
                <input type="text" />
            </dojo:ContentPane>
            <dojo:ContentPane selected="false" label="Label 2" >
                <input type="text" />
            </dojo:ContentPane>
        </dojo:AccordionContainer>
    </span>

As a temporary workaround, we added the following CSS3 Selectors to stop the problem:

div div.accordionDetail {  
     visibility: hidden; 
}
div[class*='-selected'] div.accordionDetail {  
     visibility: visible;
}

Change History (6)

comment:1 Changed 12 years ago by Adam Peller

Component: GeneralAccessibility
Milestone: 0.4
Owner: changed from anonymous to simonjb

I'm not sure to what level we supported keyboard navigation in 0.4. Can you check to see how this works in 0.9?

comment:2 Changed 12 years ago by bill

Milestone: 1.0

I bet this was broken in 0.4 because the unselected panes, rather than being display:none, were display: block (but were hidden because of z-index, etc.)

And I bet it's fixed in 1.0 because now the unselected panes are display:none. But need to check.

comment:3 Changed 12 years ago by bill

PS: the problem is that it's tabbing into an input in an unselected pane, right?

comment:4 Changed 12 years ago by guest

Bill -

You are correct. The problem is that it tabs into the input in the unselected pane. For what its worth, the CSS solution was meant merely a workaround for us. I'm sure there's a deeper underlying cause. I haven't had time to test it with .9 yet.

Josh

comment:5 in reply to:  1 Changed 12 years ago by guest

Replying to peller:

I'm not sure to what level we supported keyboard navigation in 0.4. Can you check to see how this works in 0.9?

FYI - I just tested this with .9 and it seems to work perfectly. I'm assuming we can close this ticker or at least let it live on the .4 branch?

Thanks,

Josh

comment:6 Changed 12 years ago by bill

Milestone: 1.00.9beta
Resolution: fixed
Status: newclosed

Great, that's what I expected. Yeah, I'm gonna close this bug since we don't have plans to support keyboard stuff on 0.4 (and also since it would be a major change to get it to work.)

Note: See TracTickets for help on using tickets.