Opened 16 years ago

Closed 15 years ago

#363 closed enhancement (wontfix)

Rename jum? Maybe dojo.unit?

Reported by: skinner Owned by: anonymous
Priority: low Milestone: 1.0
Component: TestFramework Version: 0.2
Keywords: Cc: [email protected]
Blocked By: Blocking:


It seems like the dojotoolkit project is actively maintaining its own unit test tools, and the dojo JUM code seems to be a modified fork of Mark Anderson's "JS Unit Manager".

Would it make sense to have the dojo unit test methods in some dojo namespace, so that unit tests could be written with calls like dojo.unit.assert() instead of jum.assert()? That might help make it clear who's maintaining the code, and where to look for documentation.

Change History (2)

comment:1 Changed 16 years ago by dylan

Milestone: 0.6

comment:2 Changed 15 years ago by Adam Peller

Resolution: wontfix
Status: newclosed

replaced by DOH

Note: See TracTickets for help on using tickets.