Opened 12 years ago

Closed 12 years ago

#3592 closed defect (fixed)

Show: strange this._options member

Reported by: bill Owned by: dante
Priority: high Milestone: 0.9
Component: Dojox Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Looking at the code to presentation/_base.js it seems like this._options is referenced but never set. Is this a bug?

And then later you delete it by calling parentNode.removeChild(this._options). Maybe should call dojo._destroyElement() instead. But it's hard for me to tell because I'm not sure what that code is doing.

Change History (1)

comment:1 Changed 12 years ago by dante

Resolution: fixed
Status: newclosed

not a bug, unless templated attachPoint nodes _need_ to be defined in module? used for show navigation select box in template as a holder, populated by cloning it for each child slide, then removing the orig. ref.

updated to use dojo._destroyElement, though will be in _next_ revision [lots of b0rken enhancements not ready to land] ... closing this.

Note: See TracTickets for help on using tickets.