Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3562 closed defect (invalid)

only first validation alert spoken by the screen reader

Reported by: Becky Gibson Owned by: ptbrunet
Priority: high Milestone: 1.0
Component: Accessibility Version: 0.9
Keywords: Cc: ptbrunet
Blocked By: Blocking:

Description

We use tooltips (which have a waiRole of alert) to display validation messages. Only the first message is spoken by the screen reader. When you make a change to the control and a second messge gets displayed the screen reader does not speak it. This may be a screen reader or Firefox issue - needs investigation.

Change History (6)

comment:1 Changed 12 years ago by Becky Gibson

Milestone: 0.91.0

comment:2 Changed 12 years ago by ptbrunet

Owner: changed from Becky Gibson to ptbrunet

comment:3 Changed 12 years ago by ptbrunet

Cc: ptbrunet added

Here is the test case: http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_validate.html 1) Navigate down to the Age field and press enter to enter forms mode. 2) An ALERT event is fired telling the user what to do and JAWS reads it, but two times instead of once. 3) As a secondary test enter a letter instead of a number. 4) Another ALERT is fired and read, but again two times instead of once.

This looks like a JAWS problem. I am checking with them. I tested using JAWS build 9.0.262 Beta.

Will test Window-Eyes next.

comment:4 Changed 12 years ago by ptbrunet

Window-Eyes 6.1 (build of April 11) exhibits the originally reported behavior. (JAWS doesn't, but see the prior comment on how it behaves.)

comment:5 Changed 12 years ago by ptbrunet

Resolution: invalid
Status: newclosed

Using JAWS 9.0 driver 289 FF2 fails but FF3 3.0a8pre works, i.e. there are no double announcements of the alert.

Window Eyes 6.1D fails as originally reported, i.e. only the first alert is heard. This was reported to GW Micro and is their bug 4296. BTW, GW Micro could argue that this is working as designed. It seems like a reasonable thing to not report the subsequent alerts if the focus remains in the field.

I'll close it as "invalid". I wish there was a closing code for "the bug is in another product".

Note: See TracTickets for help on using tickets.