Opened 12 years ago

Closed 12 years ago

#3550 closed defect (duplicate)

0.9: XML handling severely broken in IE 6

Reported by: Jared Jurkiewicz Owned by: alex
Priority: high Milestone: 0.9beta
Component: IO Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

0.9: XML handling severely broken in IE 6

This happened in the past couple days. Something with how xhrGet handles the parameter handleAs: "xml" has severely broken on IE 6. Namely, it passes the deferred callback a completely unusable object. This is breaking the dojox.data.OpmlStore? and dojox.data.XmlStore? at a minimum. anyone using xhrGet on IE 6 and handleAs xml are broken. The same testcase works fine on Firefox 2.0, Safari beta 3, Opera 9.2, etc.

Output from Firefox 2.0 in console:

XML object is type: object XML object toString is: [object XMLDocument] XML content is: <root> <child/> <child>Text here</child> <foo/> </root> Trying to dump attribute i: load with value function load() { [native code] } Trying to dump attribute i: nodeName with value #document Trying to dump attribute i: nodeValue with value null .. .

Output on IE 6 for the same code:

XML object is type: object XML object toString is: XML content is: undefined On Error attribute: name value is: TypeError? On Error attribute: message value is: Object doesn't support this action On Error attribute: number value is: -2146827843 On Error attribute: description value is: Object doesn't support this action

The errors come from the part of the test where it tries to iterate over the attributes of the object and emit the values.

Attachments (3)

simple.xml (80 bytes) - added by Jared Jurkiewicz 12 years ago.
Test XML file to load
test_xhrGet.2.html (1.3 KB) - added by Jared Jurkiewicz 12 years ago.
Test HTML file to load it.
test_xhrGet.html (1.3 KB) - added by Jared Jurkiewicz 12 years ago.
Test HTML file to load it.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by Jared Jurkiewicz

Attachment: simple.xml added

Test XML file to load

Changed 12 years ago by Jared Jurkiewicz

Attachment: test_xhrGet.2.html added

Test HTML file to load it.

Changed 12 years ago by Jared Jurkiewicz

Attachment: test_xhrGet.html added

Test HTML file to load it.

comment:1 Changed 12 years ago by Jared Jurkiewicz

Note to run the testcase, just drop it in the root of your dojo and dojox extraction. The files should be peers to dojo and dojox.

Eg:

dojo/ dojox/ simple.xml test_xhrGet.html

comment:2 Changed 12 years ago by Jared Jurkiewicz

And trying this again ... if I open the file locally, I get this failure. If I run it through a HTTP server ... it works. What the heck?

This IS IE 6, not 7. It doesn't require files to be served through a server.

comment:3 Changed 12 years ago by James Burke

Resolution: duplicate
Status: newclosed

This seems to be a duplicate of #3294. Closing as such.

Note: See TracTickets for help on using tickets.