Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3548 closed defect (fixed)

issues with dialog and tooltip dialog in high contrast mode

Reported by: Becky Gibson Owned by: davidb
Priority: high Milestone: 1.0
Component: Accessibility Version: 0.9
Keywords: Cc: davidb
Blocked By: Blocking:

Description

1) Tooltip dialog displays in high contrast mode in FF 2 and dialog does not - I thought that dialog didn't work due to a FF2 bug so need to figure out why tooltip dialog works and dialog doesn't and fix dialog.

2)dialog background is blank the first time dialog is opened in high contrast mode in FF2. Works correctly the second time dialog is opened. I think this has to do with fadeIn.play().

3) In IE 7 tooltip dialog does not display properly the first time it is invoked when in high contrast mode.

Attachments (1)

3548.diff (397 bytes) - added by davidb 12 years ago.
trivially fixes dialog issue. need to test to see if any gotchas.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 12 years ago by Becky Gibson

Regarding #1 - tooltip dialogs are not transparent in Firefox 2 because they are displayed within an iframe. Regular dialogs are not in an iframe and thus they bleed-though in FF2. Since this is a FF2 bug that has been fixed in FF3 I don't see any reason to change the implementation of normal dialogs.

comment:2 Changed 12 years ago by bill

But regular dialogs have a DialogUnderlay? behind them that grays out the screen, and also contains an iframe.

comment:3 Changed 12 years ago by davidb

Cc: davidb added

comment:4 Changed 12 years ago by davidb

severity: normalminor
  1. I can't recreate this.
  2. Confirmed
  3. Can't recreate.

Will investigate 2 a bit more. Seems low impact.

comment:5 Changed 12 years ago by davidb

Owner: changed from Becky Gibson to davidb
Status: newassigned

comment:6 Changed 12 years ago by davidb

Milestone: 0.91.0

Remaining issue is lower priority... moving to 1.0 milestone.

comment:7 Changed 12 years ago by davidb

I suspect this might be a wontfix. Could we live with a wontfix here?

Could we request a mode where animations are skipped? This would likely involve having the effects in dojo._Animation check for a flag or something.

I'm doubtful a fix will be backported to FF2. I'm not sure where the fix might be hiding on FF trunk.

comment:8 Changed 12 years ago by Becky Gibson

The proposed wontfix is just for #2, right? Is is also an issue in FF3? Also, I still see #1 as an issue in FF2 - the dialog is transparent. The first time a dialog is displayed it seems like it is not transparent due to issue #2 - if you close and display the dialog again, it is transparent.

comment:9 Changed 12 years ago by davidb

Update from phone meeting: I will look into #1, and create a new bug for #1 targeting 1.1.

comment:10 Changed 12 years ago by davidb

(Make that create a new bug for #2 sorry)

Changed 12 years ago by davidb

Attachment: 3548.diff added

trivially fixes dialog issue. need to test to see if any gotchas.

comment:11 Changed 12 years ago by davidb

Testing regular non-highcontrast behaviour seems to work with patch:

  • Mac FF2 OK
  • Win FF2 OK
  • Win FF3 OK
  • Win IE7 OK
  • Mac Saf OK

Tested high-contrast works with patch:

  • Win FF2 OK
  • win IE7 OK

Tempted to check this in...

comment:12 Changed 12 years ago by davidb

Becky, here is the visual experience for windows high contrast mode with this patch:

  • FF2 on Windows will black out the page consistently, showing only the dialog
    • The page will not show through the dialog on the first or subsequent invocations.
      • I think this is better 'glitch' than having the page bleed through.
    • I suspect there is some odd interaction with FF2 and fx in high contrast.
    • I think to get this consistent with IE7 or FF3 we need to fight with dojo fx <-> FF2 interaction. Not sure. I've spent a full day on this.
  • IE7 and FF3 will still black out only the page behind the dialog, arguably better.

I think this situation is pretty good. Shall I commit? Is it worth documenting the FF2 inconsistency?

comment:13 Changed 12 years ago by davidb

Resolution: fixed
Status: assignedclosed

(In [10987]) Fixes #3548, removes a suspect line, now gives FF2 highcontrast mode dialogs acceptable behaviour.

comment:14 Changed 12 years ago by davidb

Note: See TracTickets for help on using tickets.