Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#3523 closed defect (fixed)

Button's width decreases when clicking arrow

Reported by: haysmark Owned by: dante
Priority: blocker Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Ever since [9255], the arrow button on ComboBox? has been shrinking on click in FF2, both in Windows and in Linux, and probably on OSX too. To reproduce:

  1. Load test_FilteringSelect in FF2: http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_FilteringSelect.html.
  2. Click an arrow button to open a menu. The button shrinks on click!

This problem does not occur in [9254].

Change History (10)

comment:1 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [9328]) The complicated DOM for buttons and comboboxes was breaking FF, so that clicking a button would make the arrow <td> get narrower. Use simpler DOM for the button. Seems to fix the problem, and looks the same (even noir). Fixes this bug.

There remains a problem with the arrow not being vertically centered after click (refs #3542)

comment:2 Changed 12 years ago by bill

Milestone: 0.9beta0.9
Resolution: fixed
Status: closedreopened

comment:3 Changed 12 years ago by bill

Summary: Regression in [9255] in _FormWidgetButton's width decreases when clicking arrow

comment:4 Changed 12 years ago by dante

Owner: changed from bill to dante
Status: reopenednew

comment:5 Changed 12 years ago by dante

may have been broken in [9800] (only real ComboBox? related checkin from day before broken nightly 7-25-07)

comment:6 Changed 12 years ago by dante

sorry, i meant [9802] ...

comment:7 Changed 12 years ago by dante

Milestone: 0.91.0

haven't been able to track down cause fully. out of time for this, sorry.

comment:8 Changed 12 years ago by guest

The FilteringSelect? issue was solved by [10745]
There is still a problem with the dijit button test (fourth button, "save") in test_Button.html
Regards,

Nicola

comment:9 Changed 12 years ago by dante

Resolution: fixed
Status: newclosed

haysmark: i think bill inadvertantly fixed this with his form widget changes. The only size changes I'm seeing anymore are in test_Button.html, and it's getting wider only because the popup needs to be wider than the button, and it pushed the next button over 3 or 4px ... nothing getting smaller at all. marking as fixed, but please reopen if this is persisting.

comment:10 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.