Opened 12 years ago

Closed 12 years ago

#3489 closed defect (fixed)

Regressions in [9236]

Reported by: haysmark Owned by: haysmark
Priority: high Milestone: 0.9beta
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by haysmark)

  1. Selecting an option in ComboBox? creates an error
  2. In test_ComboBox_destroy, if you click the killit button while the menu is still open, you get the same error.
  3. Pressing backspace in an empty ComboBox? field causes the popup to flash twice before closing
  4. #2685 is reopened for ContentPanes? containing ComboBoxes?. popup.js creates an error after following the procedure listed there.

Change History (6)

comment:1 Changed 12 years ago by Douglas Hays

Seems to be a regression created by [9236]

comment:2 Changed 12 years ago by haysmark

Description: modified (diff)
Priority: normalhigh
severity: normalmajor
Summary: [ComboBox] Calls close twiceRegressions in [9236]

comment:3 Changed 12 years ago by haysmark

Description: modified (diff)

comment:4 Changed 12 years ago by Douglas Hays

(In [9244]) References #3489. Fixes issue 1. Proxy commit for haysmark. Addresses regression in [9236] that created an error in ComboBox? when you selected an option from the menu popup.

comment:5 Changed 12 years ago by bill

Hi. I told Alex to roll back [9236] but feel free to go ahead and do it rather than waiting for him.

comment:6 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [9246]) Rollback [9236].

Making popup closing asynchronous is complicated and isn't suitable to a quick fix like this.

Fixes #3489, #2685. Refs #3360.

Note: See TracTickets for help on using tickets.