Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#3483 closed defect (fixed)

[ComboBox] autocomplete=true replaces text on arrow click

Reported by: haysmark Owned by: haysmark
Priority: high Milestone: 0.9beta
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

If you open the menu from an arrow click, the contents of the textbox are cleared and replaced with the first item on the list. The text should remain the same.

Change History (2)

comment:1 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [9239]) Fixes #3483, #3485. Proxy commit for haysmark. Clicking the arrow button on a ComboBox? with autocomplete=true does not replace the text in the textbox with the first item in the list. If you perform multiple searches on a ComboBox?, ComboBox? will only pay attention to the results of the last search. ComboBox? is still broken due to regressions being tracked in #3489.

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.