Opened 12 years ago

Closed 12 years ago

#3455 closed defect (fixed)

dojo.coords().y (and probably x), wrong value on Safari3 when page scrolled

Reported by: bill Owned by: sjmiles
Priority: high Milestone: 0.9
Component: HTML Version: 0.9
Keywords: 4dijit Cc:
Blocked By: Blocking:

Description (last modified by bill)

dojo.coords(node, true) is supposed to return the absolute position of a node.

It works correctly on FF mac, but on Safari3, the value returned depends on how much you scroll the page (as though I had called dojo.coords(node, false), I guess)

Tested on test_Dialog.html, for the lower link to show a TooltipDialog?. The TooltipDialog? on Safari shows up in the wrong place when the page is scrolled.

Change History (11)

comment:1 Changed 12 years ago by bill

(In [9189]) Fix/workaround drop down positioning on Safari on scrolled page (refs #3455)

comment:2 Changed 12 years ago by bill

(In [9193]) Ah, dojo.coords() (x,y) is the absolute position, and (t,l) is position relative to the nearest position:relative/absolute ancestor.

Fixes #3465, and removes workaround for #3455 (refs #3455), so that bug has to be fixed for real.

comment:3 Changed 12 years ago by bill

Description: modified (diff)
Keywords: 4dijit added
Milestone: 0.90.9beta

comment:4 Changed 12 years ago by bill

Description: modified (diff)

comment:5 Changed 12 years ago by bill

(In [9350]) Specify icons in buttons via CSS rather than <img> tag. The CSS for icons is either in tundra.css (for the editor icons), or in the customer's css file (for custom icons).

Toolbar buttons have an icon and text defined but you can control which shows up via CSS rules (the text needs to show up if dijit_a11y is set). Haven't created those rules yet though, so for now both icon and text show up.

Need to doublecheck a11y stuff; I think I might have broken it.

Refs #3455.

When MenuItem? is converted to extend Button it will inherit this method of setting icons.

comment:6 Changed 12 years ago by bill

(In [9354]) Don't need these individual files anymore; using editor.gif sprite instead. Refs #3455.

comment:7 Changed 12 years ago by Adam Peller

Owner: changed from Bryan Forbes to sjmiles

comment:8 Changed 12 years ago by sjmiles

Resolution: worksforme
Status: newclosed

Can't reproduce, please provide a test case if you still have a problem.

comment:9 Changed 12 years ago by bill

Resolution: worksforme
Status: closedreopened

Not sure what you mean; I listed a testcase in the original bug description. Would you like a different testcase?

comment:10 Changed 12 years ago by sjmiles

We messed up, sorry. Can reproduce it now.

comment:11 Changed 12 years ago by sjmiles

Resolution: fixed
Status: reopenedclosed

(In [10186]) Make toPixelValue translate 'medium' to 4, hack refs #3874.
Repair scrolling adjustment in _abs, fixes #3455.

Note: See TracTickets for help on using tickets.