Opened 12 years ago

Closed 12 years ago

#3402 closed defect (wontfix)

Dijit SplitContainer doesn't work when contained in a ContentPane

Reported by: guest Owned by: bill
Priority: high Milestone: 1.0
Component: Dijit Version: 0.9
Keywords: SplitContainer Cc:
Blocked By: Blocking:

Description

In this case SplitContainer? doesn't work. It doesn't resize and reposition the two child, and I can't see the "sizer".

<div dojoType="dijit.layout.ContentPane?" style="width:100%; height:100%" >

<div dojoType="dijit.layout.SplitContainer?" style="width:100%; height:100%" >

<div dojoType="dijit.layout.ContentPane?" sizeMin="200">

Left

</div> <div dojoType="dijit.layout.ContentPane?" sizeMin="200">

Right

</div>

</div>

</div>

Change History (4)

comment:1 Changed 12 years ago by bill

Milestone: 0.9beta1.0

You really shouldn't be putting a SplitContainer? inside a ContentPane?. Please attach the entire testcase.

comment:2 Changed 12 years ago by guest

###MAIN PAGE index.php###

<div id="external_container" style="width: 100%; height: 100%;" dojoType="dijit.layout.LayoutContainer?" layoutChildPriority="top-bottom" >

<div id="topbar" dojoType="dijit.layout.ContentPane?" cacheContent="false" layoutAlign="top" >

Here the menu to change the href of the 'client container'

</div>

<div id="client_container" href="f2.php" dojoType="dijit.layout.ContentPane?" cacheContent="false" >

Loading...

</div>

</div> ###THIS IS THE SECOND FILE : f2.php###

<div id="main_split" style="height:100%;width:100%;" dojoType="dijit.layout.SplitContainer?" sizerWidth="5" activeSizing="true" persist="false" >

<div id="cp-left" dojoType="dijit.layout.ContentPane?" cacheContent="false" sizeMin="400" sizeShare="20" >

<b>Cerca tra i contatti: </b> <input id="anaSearchInline" type="textbox" ></input> <div id="lista_anagr" dojoType="dojox.widget.Table3" singleSelectionMenu="singlesel" multipleSelectionMenu="" allowMultipleSelection="false" ></div>

</div> <div id="cp-client" style="text-align:center;" dojoType="dijit.layout.ContentPane?" cacheContent="false" sizeMin="200" sizeShare="80" >

<div id="lista_ri_anagrafiche" dojoType="dojox.widget.Table3" singleSelectionMenu="singlesel" multipleSelectionMenu="" allowMultipleSelection="true" ></div>

</div>

</div>

comment:3 Changed 12 years ago by guest

I really need this... The problem is also with:

TabContainer?

LinkPane?

dinamically->SplitContainer?

comment:4 Changed 12 years ago by bill

Resolution: wontfix
Status: newclosed

Actually I meant to *attach* the testcase using the "Attach File" button, but anyway, the thing you listed above: TabContainer

LinkPane

dynamically->SplitContainer

That won't work because the TabContainer? sizing info doesn't get passed down to the SplitContainer?, since there's a LinkPane? in the middle.

It's also curious that your page has no <html> or <body> tag. In general if you want something to take up the whole screen you say

html, body{ width: 100%, height: 100%, padding: 0; border: 0; }

See the Mail demo from 0.4 for an example.

Sorry, dijit just can't support the kind of setup you have; if you need to dynamically load stuff like SplitContainers? you'll have to write your own code to wire that together.

Note: See TracTickets for help on using tickets.