Opened 12 years ago

Closed 12 years ago

#3397 closed defect (fixed)

In RichText widget 'domeNode' instead of 'domNode'

Reported by: bradneuberg Owned by: bradneuberg
Priority: high Milestone:
Component: Dijit Version: 0.9
Keywords: richtext, dijit Cc:
Blocked By: Blocking:

Description

Found a typo that creates a bug in RichText?. In the method open() on the approximate line 274 (approximate because I have a bunch of console.debug() print outs to fix other bugs in this component that change the line number a bit), there is the following code:

if(!dojo.isSafari){

FIXME: VERY STRANGE safari 2.0.4 behavior here caused by moving the textarea. Often crashed the browser!!! Seems fixed on webkit nightlies. dojo.place(this.domeNode, this.textarea, "before");

}

notice that it says 'domeNode' rather than 'domNode'. Searching, I don't find this method name anywhere else; I'm going to assume it's a typo.

Change History (1)

comment:1 Changed 12 years ago by Brad Neuberg

Resolution: fixed
Status: newclosed

(In [9080]) fixes #3397

Note: See TracTickets for help on using tickets.