Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#3385 closed defect (fixed)

dijit.util.BackgroundIframe is broken in IE6 and FF2

Reported by: simonjb Owned by: bill
Priority: high Milestone: 0.9beta
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

The dijit.util.BackgroundIframe is broken in IE6 and FF2. Consequences:

  • in IE6 the iframe is the wrong size and an error is generated: "Error: Object required"
  • in FF2 menus are transparent in Windows high-contrast mode

To reproduce:

  1. open dijit/tests/test_Menu.html in IE6 or in FF2 (high-contrast mode for FF)
  2. open the menu by right clicking

Change History (5)

comment:1 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [9100]) Various fixes/cleanp that seem to make the menu errors on IE go away. Fixes #3385, hopefully.

comment:2 Changed 12 years ago by bill

(In [9102]) default background for popups in case the popup itself doesn't specify one, like for Calendar. Refs #3385

comment:3 Changed 12 years ago by bill

(In [9103]) Don't use display=block because they messes up tables; specifically it doesn't let the stretch out to a specified height, so the drop down calendar looks funny. Refs #3385

comment:4 Changed 12 years ago by bill

(In [9104]) Remove default background color; was making menu look funny. Refs #3385

comment:5 Changed 9 years ago by bill

(In [22846]) Remove unneeded CSS rules. These rules might have been left over from when menus etc. were semi-transparent. In true high-contrast mode background-color setting is ignored anyway.

Tested Menu and TooltipDialog on IE and FF in high contrast mode and they look fine w/out this rule. Fixes #11695, refs #3385 ([9100]).

Note: See TracTickets for help on using tickets.