Opened 13 years ago

Closed 13 years ago

#3357 closed defect (fixed)

Regression in [8995]: place.js broken in FF2 and IE7, popups have 0 height

Reported by: haysmark Owned by: haysmark
Priority: high Milestone: 0.9beta
Component: Dijit Version: 0.9
Keywords: Cc: haysmark
Blocked By: Blocking:

Description

The new iframe wrapper code for PopupManager? (popup.js now) in [8995] caused dojo.marginBox in place.js to start returning 0 for width and height of the ComboBox? and FilteringSelect? popups. Consequently, the popups don't work anymore because they have 0 height.

This is probably because _open attached the wrapper to the dom but did not give the browser time to render before place.js made the dojo.marginBox call.

Change History (2)

comment:1 Changed 13 years ago by haysmark

Cc: haysmark added
Owner: changed from bill to haysmark
Status: newassigned

comment:2 Changed 13 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [9020]) Fixes #2685, #3357. Proxy commit for haysmark. Addresses regression created by [8995] where the popups had 0 height. _DropDownTextBox does not set position:absolute on the popup anymore. FormElement? widgets now have their mouse handlers properly disconnected on destroy. ComboBox? on destruction attempts to call close before destroying its popup. popup.js close checks to see if the popup widget exists before setting its style.

Note: See TracTickets for help on using tickets.