Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3337 closed defect (wontfix)

build system corrupts some characters in localized files

Reported by: guest Owned by: Adam Peller
Priority: high Milestone:
Component: Internationalization Version: 0.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

Observed in Version 0.4.3

Using the build system to build your own dojo results in some corrupt strings (like "ufffd?") in some localized files such as srci18ncalendar lshugregorian.js. They appear to be caused by a <replaceregexp> in build.xml which doesn't specify utf-8. See http://dojotoolkit.org/locale-problems-dojo-build-system for a more complete explanation.

Change History (3)

comment:1 Changed 12 years ago by Adam Peller

Component: GeneralInternationalization
Milestone: 0.4.4
Owner: changed from anonymous to Adam Peller
severity: normalmajor
Version: 0.4.2

comment:2 Changed 12 years ago by Adam Peller

Resolution: wontfix
Status: newclosed

since there's a workaround published (thanks, GregBishop?) and no plans for a 0.4.4 build, I'm closing this

comment:3 Changed 12 years ago by (none)

Milestone: 0.4.4

Milestone 0.4.4 deleted

Note: See TracTickets for help on using tickets.