Opened 12 years ago

Closed 12 years ago

#3320 closed defect (fixed)

test_parent_constraints.html: margin problem with IE6

Reported by: Douglas Hays Owned by: sjmiles
Priority: high Milestone: 0.9
Component: DnD Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

I modified test_parent_constraints.html and added
margin: 20px;
to the moveable class definition. The margin is honored in FF2, but when using IE6, there doesn't appear to be a top or left margin and the right and bottom margin appear to be double in size.

Change History (6)

comment:1 Changed 12 years ago by Douglas Hays

Milestone: 0.4.40.9

comment:2 Changed 12 years ago by Eugene Lazutkin

Owner: changed from Eugene Lazutkin to sjmiles

I confirmed it with IE7 and Op9. The only thing needed in order to see it is to add margins to the "moveable" class like that:

.moveable {
  background: #FFFFBF;
  border: 1px solid black;
  width: 300px;
  padding: 10px 20px;
  margin: 20px; /* this is the added line */
  cursor: pointer;
}

Visually it looks like 40px margins were added on right and bottom sides instead of 20px all on 4 sides.

I am reassigning this bug to Scott to look at.

comment:3 Changed 12 years ago by sjmiles

(In [9065]) Safari: add a null test and return a golem object from getComputedStyle if necessary. Refs #2686.

Adjust _setContentBox for TABLE and BUTTON, refs #3296.

Move left/top margin box adjustments out of _set and into _get. Refs #3297 and #3320.

Let _getContentBox fall back to offsetWidth/Height if clientWidth/Height are 0. Refs #3378.

comment:4 Changed 12 years ago by sjmiles

(In [9068]) Add DnD test for parent_constraints with margins. Refs #3320.

comment:5 Changed 12 years ago by sjmiles

(In [9070]) Add overflow: hidden to parent in DnD test to avoid confusion about the results. Refs #3320.

comment:6 Changed 12 years ago by sjmiles

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.