Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3319 closed defect (wontfix)

firebug console swallows dojo.lang.declared class method thrown exception

Reported by: guest Owned by: anonymous
Priority: high Milestone:
Component: Core Version: 0.4.2
Keywords: Cc: rhys@…
Blocked By: Blocking:

Description

Kind of a weird one...

Firefox 1.5 and Firefox 2.0 using Firebug 1.05. Confirmed on both Windows & Linux.

I dojo.lang.declare a class Foo with a method bar() that throws a new TypeError?. I then instantiate foo and invoke foo.bar from Firebug's console. Firebug swallows the TypeError? silently instead of displaying the TypeError? in the console as expected.

I've been in contact with the Firebug folks, and we can't reproduce this using regular Javascript OOP practices. Check out the complete thread http://groups.google.com/group/firebug/browse_thread/thread/613cbc91dba58422.

Attachments (2)

DojoDeclareBreaksFirebugExceptionsInConsole.html (1.3 KB) - added by guest 12 years ago.
Recreate using dojo-0.4.3 off AOL's CDN
DojoDeclareBreaksFirebugExceptionsInConsole.2.html (991 bytes) - added by Adam Peller 12 years ago.
Show bug, sans Dojo

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by guest

Recreate using dojo-0.4.3 off AOL's CDN

Changed 12 years ago by Adam Peller

Show bug, sans Dojo

comment:1 Changed 12 years ago by Adam Peller

Resolution: wontfix
Status: newclosed

A little unfair to blame Dojo on this one. Prototype should fall into the realm of "regular JavaScript? OOP practice" Works fine in Drosera :) I'd chalk it up to another jsd mystery. See attached.

Thanks for forcing me to look at this, though. I think it explains a LOT of times I couldn't find exceptions in Firebug.

comment:2 Changed 12 years ago by guest

Thank you for your time on this one. I've taken the dojo-less recreate back to the Firebug folks http://groups.google.com/group/firebug/browse_thread/thread/613cbc91dba58422.

comment:3 Changed 12 years ago by guest

No change to the defect, just a related hint...

It looks like Firebug 1.05 will show the error if you open up Firefox's [about:config] page and set extensions.firebug.showChromeErrors to true. The capability exists but isn't presented by the Firebug UI as of 1.05.

Note: See TracTickets for help on using tickets.