Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#3288 closed defect (fixed)

Dijit: standardize attribute names

Reported by: bill Owned by: bill
Priority: high Milestone: 0.9beta
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Use "title" for Dialog, Titlepane, and children of PageContainer/TabContainer/AccordionContainer?, since title is part of the HTML DTD.

For Button, MenuItem?, etc., use "text" and "icon" to represent each of those things, rather than "label" (which has another meaning in HTML), or "caption", which just doesn't sound right.

Change History (10)

comment:1 Changed 13 years ago by bill

Status: newassigned

comment:2 Changed 13 years ago by bill

(In [8941]) Use "title" as attribute name for widgets that have a title and content. Also some other cleanup, including removing classNames as parameters of Accordion. Also changed parser to workaround problem with numeric value being undefined. Refs #3288

comment:3 Changed 12 years ago by bill

(In [9343]) In markup, prefer innerHTML to attributes (for Button and Menu labels). Refs #3288

comment:4 Changed 12 years ago by bill

(In [9346]) In markup, prefer innerHTML to attributes (for Button and Menu labels). Refs #3288

comment:5 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [9347]) Standardize on "label" (not caption). Fixes #3288.

comment:6 Changed 12 years ago by bill

(In [9447]) Support setDisabled() as a public method rather than separate enable()/disable() methods. Refs #3288.

comment:7 Changed 12 years ago by bill

(In [9448]) Name callback onChange(), rather than onValueChanged(), since onChange() is an HTML standard. Refs #3288, and fixes #3462.

comment:8 Changed 12 years ago by bill

(In [9480]) Remove cruft (onChange is defined in _FormWidget). Refs #3288.

comment:9 Changed 12 years ago by bill

(In [9544]) Change "selectedColor" to "value" and onColorSelected() to onChange(). I think we still need to ColorPalette? to show a currently selected color in the same way that _Calendar shows the currently selected date. Refs #3288.

comment:10 Changed 12 years ago by bill

(In [9721]) For toggle widgets (ToggleButton?, Checkbox, Radio), use "checked" rather than "selected", since "checked" is an HTML standard. and also to allow menu items (and tree nodes, maybe) to be checked and selected (ie, highlighted) independently.

Refs #3288 (and see also [9223])

Note: See TracTickets for help on using tickets.