Opened 12 years ago

Closed 12 years ago

#3237 closed defect (fixed)

Rename JsonPService to JsonpService

Reported by: James Burke Owned by: Dustin Machi
Priority: high Milestone: 0.9beta
Component: IO Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Worked with Dustin on this. The JsonPService should be called JsonpService? to fit with the naming convention. JsonP was used because in dojo.io.script, the parameter jsonpParam was a bit deceptive: the double p's caused lots of typos, and it is a bit unclear (is it the parameter name or value?).

Dustin and I agreed to change the dojo.io.script parameter name from jsonpParam to callbackParamName, and once this is done, convert JsonPService to JsonpService?.

Change History (4)

comment:1 Changed 12 years ago by James Burke

(In [8873]) Refs #3237: changes dojo.io.script's jsonpParam to callbackParamName

comment:2 Changed 12 years ago by James Burke

(In [8874]) Refs #3237: changes dojo.io.script's jsonpParam to callbackParamName

comment:3 Changed 12 years ago by James Burke

Owner: changed from James Burke to Dustin Machi

Reassigning to dmachi for the JsonPService renaming part.

comment:4 Changed 12 years ago by Dustin Machi

Resolution: fixed
Status: newclosed

(In [8991]) Rename JsonPService.js to JsonpService?.js for consistency with the io system. fixes #3237

Note: See TracTickets for help on using tickets.