Opened 12 years ago

Closed 12 years ago

#3230 closed defect (fixed)

Empty drag possible

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 0.9beta
Component: DnD Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

it is possible to do an "empty drag", to reproduce this add:

	node.style.margin="25px";

at main_creator in demos/dnd2/flickr_viewer.html (when creating a div for table node) and try to drag that margin (there is avatar with message: moving 0 items)

To avoid this situation we should check nodes.length for example at manager.startDrag simple

if ( !nodes.length ) { return; } 

should do the trick.

Change History (3)

comment:1 Changed 12 years ago by Eugene Lazutkin

Owner: changed from psowden to Eugene Lazutkin
severity: majornormal

I am changing the severity because this bus is essentially harmless.

comment:2 Changed 12 years ago by Eugene Lazutkin

Status: newassigned

comment:3 Changed 12 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

(In [8884]) Bug: an empty drag is possible. Fixes #3230.

Note: See TracTickets for help on using tickets.