Opened 13 years ago

Closed 13 years ago

Last modified 9 years ago

#3215 closed defect (fixed)

Select: up arrow cancels popup unnecessarily

Reported by: Douglas Hays Owned by: haysmark
Priority: high Milestone: 0.9
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Using test_Select.html on IE or FF,
with focus in the textbox, down arrow opens the popup.
Another down arrow highlights the first option, and a 3rd down arrow selects the 2nd item.
Pressing up arrow moves to the 1st item and another up arrow closes the popup. I think it should move to the previous highlighted item if possible, or just stay at the 1st item.
It may be OK to close the popup if no item is highlighted.
The problem is particularly bad if you are holding down the up arrow to scan thru a long list.

Change History (2)

comment:1 Changed 13 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [8837]) Fixes #3215. Proxy commit for haysmark. Moved _highlightPrevOption next to _highlightNextOption. The behavior of pressing the up arrow in AutoCompleterMenu? is slightly different now. If you have the first option highlighted and press up, the popup does not close. It will close if you press up and there is no option highlighted.

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.