Opened 12 years ago

Closed 12 years ago

#3203 closed defect (invalid)

ie 6 sporadically does not run dj_load_init event

Reported by: guest Owned by: James Burke
Priority: high Milestone: 1.0
Component: Core Version: 0.4.1
Keywords: Cc:
Blocked By: Blocking:

Description

broswer ie 6.0.2900 sp2

After several hours of testing our users are running into the situation where the widgets on the page stop working. After placing log points at several places in the code we noticed the dj_load_init function was not being run from the onreadystatechange event. This is a sporadic problem and can not be recreated on demand. Also memory does not appear to be a problem, we can shut down the all the browsers to clear memory, and the problem will continue when we start up again.

I believe this is the point of the offending code.

if (dojo.render.html.ie && dojo.render.os.win) {

document.attachEvent("onreadystatechange", function (e) {

if (document.readyState == "complete") {

dj_load_init();

}

});

}

Change History (5)

comment:1 in reply to:  description Changed 12 years ago by guest

Replying to guest:

broswer ie 6.0.2900 sp2

After several hours of testing our users are running into the situation where the widgets on the page stop working. After placing log points at several places in the code we noticed the dj_load_init function was not being run from the onreadystatechange event. This is a sporadic problem and can not be recreated on demand. Also memory does not appear to be a problem, we can shut down the all the browsers to clear memory, and the problem will continue when we start up again.

I believe this is the point of the offending code.

if (dojo.render.html.ie && dojo.render.os.win) {

document.attachEvent("onreadystatechange", function (e) {

if (document.readyState == "complete") {

dj_load_init();

}

});

}

I'm sorry this is a 4.1 bug

comment:2 Changed 12 years ago by bill

Component: GeneralCore
Milestone: 1.1
Owner: changed from anonymous to James Burke
Version: 0.90.4.1

I haven't seen this bug. If it does occur it's obviously very important but since it's hard to reproduce I'm setting a 1.1 milestone.

comment:3 Changed 12 years ago by James Burke

Milestone: 1.11.0

I'll set this for 1.0, but it really needs a test case. I believe Mark Wubben mentioned an issue with the init/load code running in IE when there was a specific Flash case involved.

If the reporter can give a test case, that would help immensely. Otherwise, I'll be closing the bug out, since this does seem hard to reproduce (I have not come across the issue, and neither have the teams that use Dojo 0.4.3).

comment:4 Changed 12 years ago by James Burke

Milestone: 1.01.1

comment:5 Changed 12 years ago by James Burke

Milestone: 1.11.0
Resolution: invalid
Status: newclosed

Closing this out, no test case.

Note: See TracTickets for help on using tickets.