Opened 12 years ago

Closed 12 years ago

#3197 closed defect (duplicate)

0.9: dojo query Unit test is failing.

Reported by: Jared Jurkiewicz Owned by: alex
Priority: high Milestone: 0.9beta
Component: General Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

There's a failure in one of the query testcases on Firefox 2.0.0.3, IE 6.0, Seamonkey 1.1.1, WebKit?, Opera 9.2 and probably others:

PASSED test: ../../dojo/tests/_base/query.html::t::t.is(3, (dojo.query('> h3', dojo.byId('t'))).length);

PASSED test: ../../dojo/tests/_base/query.html::t::t.is(2, (dojo.query('.foo, .bar')).length);

_AssertFailure: file:///C:/dev/ajax/dojo-0.9/dojo/_base/_loader/bootstrap.js:282 doh._AssertFailure: assertEqual() failed: expected |2| but got |0|

doh._AssertFailure

ERROR IN:

(function anonymous(t) {t.is(2, dojo.query(".foo,.bar").length);})

FAILED test: ../../dojo/tests/_base/query.html::t::t.is(2, (dojo.query('.foo,.bar')).length); PASSED test: ../../dojo/tests/_base/query.html::t::t.is(2, (dojo.query('.foo')).length); PASSED test: ../../dojo/tests/_base/query.html::t::t.is(2, (dojo.query('.baz')).length); PASSED test: ../../dojo/tests/_base/query.html::t::t.is(1, (dojo.query('span.baz')).length);

Change History (2)

comment:1 Changed 12 years ago by Adam Peller

Owner: changed from anonymous to alex

comment:2 Changed 12 years ago by dylan

Resolution: duplicate
Status: newclosed

duplicate of #2423

Note: See TracTickets for help on using tickets.