Opened 13 years ago

Closed 12 years ago

#3189 closed defect (fixed)

ColorPalette: list color names, and translations, rather than hex values

Reported by: bill Owned by: Adam Peller
Priority: high Milestone: 0.9
Component: Accessibility Version: 0.9
Keywords: i18n Cc:
Blocked By: Blocking:

Description

I think Becky said that the "alt text" for each color in the color picker should be an actual color name rather than a hex value? Which then leads to translation headaches... anyway this should be built on top of [8720] after Eugene finishes adding all the other colors (see #3188)

Attachments (3)

ColorPalette.js.patch (4.2 KB) - added by Adam Peller 12 years ago.
Patch to use color names from Declan (IBM)
test_ColorPalette.html.patch (483 bytes) - added by Adam Peller 12 years ago.
test patch from Declan (IBM)
colors7x10.png (1.4 KB) - added by Adam Peller 12 years ago.
new palette from Declan, to match CSS3 colors

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by Becky Gibson

This is a duplicate of #3024 - I have closed that ticket.

comment:2 Changed 12 years ago by Adam Peller

Keywords: i18n added
Milestone: 1.00.9
Priority: normalhigh

we need these tables in place soon so give translation some lead time

comment:3 Changed 12 years ago by Adam Peller

the tables and translations have been added (see #3188 and dojo/nls/colors). you can now implement it in ColorPalette?

comment:4 Changed 12 years ago by Adam Peller

Owner: changed from dfahey to Adam Peller

Declan isn't working on Dojo anymore. Grabbing this.

comment:5 Changed 12 years ago by Adam Peller

From Declan: "Here is patch files with alt texts changed. It is a different palette now. One issue is the alt text in firefox bleeds alot. This wasn't so much of a problem with the smaller hex value strings but now firefox doesn't look pretty with images turned off. I don't know how to fix it."

Changed 12 years ago by Adam Peller

Attachment: ColorPalette.js.patch added

Patch to use color names from Declan (IBM)

Changed 12 years ago by Adam Peller

test patch from Declan (IBM)

Changed 12 years ago by Adam Peller

Attachment: colors7x10.png added

new palette from Declan, to match CSS3 colors

comment:6 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [9883]) Apply patch from Declan. Fixes #3189.

Note: See TracTickets for help on using tickets.