Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#3172 closed defect (fixed)

AutoComplete and Select widgets provide poor UI

Reported by: alex Owned by: haysmark
Priority: high Milestone: 0.9beta
Component: Dijit - Form Version: 0.9
Keywords: Cc: alex
Blocked By: Blocking:

Description (last modified by alex)

Several minor issues contribute to a poor overall experience for the Select and AutoComplete? widgets. Namely:

  • Option drop-downs do not take the width of the option box (either inclusive or exclusive of the drop-down button). Torrey's Tundra design for the widgets indicates that they will use drop-downs whose border-size is that of the input-box plus the drop-down arrow (inclusive).
  • input hint tooltips obscure options and the ability to click on them. This is maddening, even in demos.
  • the drop-down images used in the widgets right now is larger/darker than the one prescribed in the theme
  • on FireFox?, the drop down is separated from its generating textarea by a small distance (5px or so)
  • on webkit, the bottom border of the drop-down area is missing.

Change History (9)

comment:1 Changed 12 years ago by alex

Description: modified (diff)

comment:2 Changed 12 years ago by alex

also, while it's good that the drop-down now supports images, has there been any thought given to providing the ability to provide more explanitory text to an option? Or for alternative-row coloring? Also, it would seem natural to use a fade animation for the drop-downs.

comment:3 Changed 12 years ago by bill

Owner: changed from bill to haysmark

These are all good issues.

Mark should fix the width issue.

As for hints, the drop down shouldn't display at the same time as the hints. Select probably shouldn't have any hints at all, and Autocompleter... well the simplest thing is for Autocompleter not to have hints either. But if it does then they shouldn't occur at the same time as the drop down.

I filed the last 3 issues above as a separate bug (#3175) for owen to look at.

The drop down should have a fade animation, so I filed bug #7313 for that.

comment:4 Changed 12 years ago by bill

Oops, the PopupManager? bug is #3137, not what I wrote above.

comment:5 Changed 12 years ago by haysmark

I can't reproduce the problem with the ValidationTextbox? promptMessage obscuring the options. The promptMessage always appears below the options for me. Test case?

comment:6 Changed 12 years ago by bill

Actually the tooltip appears below the option list for me too, but it still looks bad to have one thing obscuring another.

comment:8 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [8867]) Fixes #3172, #3216. Proxy commit for haysmark. Popups conform to the width of the textbox. Popups appear closer to the textbox. Tooltip goes away when a _DropDownTextBox popup appears. The Tooltip now reappears if you click a _DropDownTextBox for a second time.

comment:9 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.