Changes between Initial Version and Version 6 of Ticket #3127


Ignore:
Timestamp:
Jun 1, 2008, 3:16:07 AM (11 years ago)
Author:
kriszyp
Comment:

I would think that a schema could be just per store instead of per item. This would simplify the design. Could the schema info be returned as a regular item or JS object so you don't have to have entire API just for accessing the attributes of the schema/class? That seems like terrible overkill, and an unnecessary burden on implementors. Also, why would wouldn't getItemClass be simply called getItemSchema (or getSchema if it is per store), since the API is called Schema... Or change the name of the API.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #3127

    • Property Owner changed from anonymous to skinner
    • Property Milestone changed from 1.0 to 1.3