Opened 12 years ago

Closed 7 years ago

#3121 closed task (invalid)

[meta] fill in missing tests and expand weak Core test sets

Reported by: alex Owned by: alex
Priority: low Milestone: future
Component: Core Version: 0.9
Keywords: Cc: alex
Blocked By: Blocking:

Description


Change History (32)

comment:1 Changed 12 years ago by alex

(In [8719]) adding test todo file. Refs #3121

comment:2 Changed 12 years ago by alex

(In [8781]) logging some oversights in testing. Refs #3121

comment:3 Changed 12 years ago by Eugene Lazutkin

(In [9426]) Added xhrPut() and xhrDelete() tests. Corrected an IE-specific bug (the trailing comma). Refs #3121.

comment:4 Changed 12 years ago by Eugene Lazutkin

(In [9427]) Added rawXhrPost() test. Refs #3121.

comment:5 Changed 12 years ago by Eugene Lazutkin

(In [9428]) Updated TODO. Refs #3121.

comment:6 Changed 12 years ago by Eugene Lazutkin

(In [9430]) Added testClassFunctions(). Refs #3121.

comment:7 Changed 12 years ago by alex

(In [9433]) adding isDescendant() and setSelectable() methods. Refs #3121. Still need to update dijit to use the new methods.

comment:8 Changed 12 years ago by Eugene Lazutkin

(In [9434]) Implemented an inexpensive space trimming for class strings. Refs #3121. Fixes #3604.

comment:9 Changed 12 years ago by Eugene Lazutkin

(In [9438]) Added more tests for semi-public box functions. Refs #3121.

comment:10 Changed 12 years ago by Eugene Lazutkin

(In [9439]) Added a todo item: need tests for dojo.place(). Refs #3121.

comment:11 Changed 12 years ago by alex

still need to add tests for dojo.fx

comment:12 Changed 12 years ago by alex

(In [9915]) adding a toggler class and the start of unit tests for the dojo.fx namespace. Fixes #3641. Refs #3121

comment:13 Changed 12 years ago by alex

(In [10161]) special case the ">" query. Was a major oversight that new tests helped dig up. Refs #3121

comment:14 Changed 12 years ago by alex

(In [10162]) IE doesn't recognize "v" as a whitespace char to be trimmed. Refs #3121

comment:15 Changed 12 years ago by alex

(In [10298]) NodeList?'s aren't instances of the parent docuemnt's Array class. Use a test that encodes this data. Refs #3121

comment:16 Changed 12 years ago by alex

(In [10301]) make sure that deferreds get results. Refs #3121

comment:17 Changed 12 years ago by alex

(In [10977]) catch the exception in json comment filtering. Refs #3121

comment:18 Changed 12 years ago by alex

(In [11213]) cleaning up a stray debugging call, removing the non-standard ":contains" selector, fixing ":empty", and adding tons more unit tests. Refs #3121.

comment:19 Changed 12 years ago by Bryan Forbes

(In [12085]) Added tests for combine and chain. refs #3121.

comment:20 Changed 11 years ago by alex

(In [12828]) comment cleanup and code shortening. Also expanding test cases to handle default param packing. Refs #3961. Refs #5962. Refs #3121. !strict

comment:21 Changed 11 years ago by alex

Summary: fill in missing tests and expand weak Core test sets[meta] fill in missing tests and expand weak Core test sets

comment:22 Changed 11 years ago by alex

(In [12901]) add a bit more data. Refs #3121

comment:23 Changed 11 years ago by bill

Priority: highnormal

comment:24 Changed 11 years ago by alex

(In [13057]) removing crufty dojo.back options which are no longer necessaray now that we've changed dojo.back to use an explicit init() method. Refs #3121

comment:25 Changed 11 years ago by alex

(In [13058]) query tests probably shouldn't be using debugAtAllCosts. Refs #3121

comment:26 Changed 11 years ago by dante

(In [13186]) refs #3121 - who knew you could djConfig = { popup:true } ? this was broken in rc1, adding a test case to check for regressions etc in rc2 / 1.1

comment:27 Changed 11 years ago by dante

(In [13199]) refs #3121 - cleanup the 'crude api browser' _browse.php - and make work with less forgiving php configs also make use of "ajaxyness" to prevent unnecessary js reload, and get rid of LayoutContainer? / SplitContainer? usage.

comment:28 Changed 11 years ago by dante

(In [13200]) refs #3121 - using the removal of useless comment to steal a good revision ;) (the comment was the motivation for the last checkin, so it counts)

comment:29 Changed 11 years ago by bill

Milestone: 1.2future

comment:30 Changed 8 years ago by Chris Mitchell

Owner: anonymous deleted

comment:31 Changed 8 years ago by ben hockey

Owner: set to alex
Priority: highlow
Status: newpending

this looks like it was just a placeholder for referencing in commits.

anyone care to add more details to the description?

this will automatically close in 14 days if there's no response.

comment:32 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.