Opened 14 years ago

Closed 14 years ago

#312 closed defect (invalid)

FireFox + Tree + dojo.io.IFrameIO

Reported by: derek.lakin@… Owned by: anonymous
Priority: high Milestone:
Component: Widgets Version: 0.2
Keywords: tree, widget, firefox, ie, iframeio Cc:
Blocked By: Blocking:

Description

If you require the dojo.io.IFrameIO class (for file uploading from forms for example), but also have a tree widget, then the tree cannot be loaded.

This can easily be illustrated by simply adding the following to the the Mail demo:

require(dojo.io.IframeIO);

This is only a problem in FireFox? (1.5 tested so far), not IE (6.0 tested so far).

Change History (2)

comment:1 Changed 14 years ago by david

Do you get any errors?

comment:2 Changed 14 years ago by derek.lakin@…

Resolution: invalid
Status: newclosed

I have found the cause of the problem: it was the moveChildren method that I had hacked to fix the Missing Form problem. FireFox? didn't like node.children.length, but IE was fine with that. I've changed my hack to use node.childNodes.length instead.

Note: See TracTickets for help on using tickets.