Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#307 closed defect (worksforme)

Widgets not displaying in Safari

Reported by: bryant@… Owned by: alex
Priority: high Milestone:
Component: Core Version: 0.2
Keywords: khtml safari compatibility Cc:
Blocked By: Blocking:

Description

I have a page with a tabset. in the first tab, I have a split pane with a treeview. Looks great in FF. the treeview is totally missing (and the JS console in Safari notes a null in line 2560 of dojo.js). This is Dojo 0.2.1. Also, I have a floating pane that is shown with a toggler. Works great in FF. Clicking the toggler in Safari does nothing. I suspect that the issues are related - there's an error loading the JS when the page renders and then none of the dojo elements will work.

Feel free to email me and I will send screenshots of examples of the issue.

Great product! Thanks!

Bryant

Attachments (1)

UserButton.js (976 bytes) - added by alex 13 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by alex

Milestone: 0.2.1release0.3release

comment:2 Changed 13 years ago by dylan

severity: normalmajor

I think I'm seeing a similar issue. As far as I can tell, this is a way to produce this bug:

  • instantiate a widget
  • use a node inside that widget instance as an attachment point to instantiate another widget from script... the second widget has a null domNode.

comment:3 Changed 13 years ago by alex

Owner: changed from anonymous to alex
Status: newassigned

comment:4 Changed 13 years ago by Tom Trenka

Resolution: worksforme
Status: assignedclosed

If we're understanding you correctly, the issue is a widget that is created inside another widget, preferably at runtime and not load; we just confirmed using a separate test that Safari is loading and executing things as expected.

If you can reproduce and/or isolate to one or two widgets, please open a new ticket and be a little bit more detailed in terms of what you're using. Thanks!

comment:5 Changed 13 years ago by dylan

Milestone: 0.3release0.3.1
Resolution: worksforme
Status: closedreopened

Breaks for every custom widget I have that I create from script. The domNode for the nested widget is null at the point of fillInTemplate.

I can setup an example for you if you don't see this behavior, or maybe I will harass someone at Dojo dev day to fix fix fix this one :)

comment:6 Changed 13 years ago by alex

Resolution: worksforme
Status: reopenedclosed

I'm not having any luck reproducing this. Attached is a version of the "acme userbutton" class that is extended as you suggest, however the domNode property of both the parent and child appears to be correctly initialized at the points of their respective fillInTemplate methods. You can test this by dropping the attached file into:

tests/widget/acme/UserButton.js

and then loading up:

tests/widget/acme/test_RemoteUserButton.html

Marking "worksforme" until such time as I get a reproduceable test case.

Regards

Changed 13 years ago by alex

Attachment: UserButton.js added

comment:7 Changed 12 years ago by (none)

Milestone: 0.3.1

Milestone 0.3.1 deleted

Note: See TracTickets for help on using tickets.