Opened 13 years ago

Closed 12 years ago

#3062 closed defect (invalid)

pressing space on dropdown button should toggle the associated menu

Reported by: Becky Gibson Owned by: davidb
Priority: high Milestone: 0.9beta
Component: Accessibility Version: 0.9
Keywords: Cc: simonjb
Blocked By: Blocking:

Description

Pressing space with focus on a drop down button causes the associated drop down menu to display - this is correct. Pressing space again with no menu item selected (focus is still on the button) should toggle the menu closed. Clicking on the button has the same problem - the menu is opened but not closed when the button is clicked again.

Clicking and pressing space with focus on the button should work as a toggle to open/close the menu. This is the way the enter key works (it is working properly).

Change History (12)

comment:1 Changed 13 years ago by davidb

Status: newassigned

comment:2 Changed 13 years ago by davidb

Version: 0.9

comment:3 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [8779]) Fix keyboard handling for Combobutton. Fixes #3061 and #3062. Proxy checkin for David Bolter (CLA on file).

comment:4 Changed 12 years ago by Becky Gibson

Resolution: fixed
Status: closedreopened

This may have regressed when the buttons were changed to use a table for layout. When I press space the drop down appears. Pressing space again makes the dropdown close but then it reopens again. I have the same problem if I open when enter and try and toggle close with space. But, opening via enter key and toggling closed via space works correctly. This seems to have to do with resetting previous focus.

comment:5 Changed 12 years ago by davidb

Yes, a regression.

comment:6 Changed 12 years ago by davidb

Becky, it looks like after pressing spacebar to invoke the menu, focus is going to the first selected menu item; and focus is no longer on the dropdown button. Is this correct behavior? (It goes against your ticket description).

comment:7 Changed 12 years ago by davidb

Have just discovered and posted related (blocker?) 3281.

comment:8 Changed 12 years ago by Becky Gibson

Cc: simonjb added

Actually the way this was spec'ed (http://www.dojotoolkit.org/forum/proposed-dijit-menu-keyboard-and-mouse-behavior) in a context menu the focus goes to the first item. Since the drop down button shares the menu code, focus on the first item is expected when the menu is used in the drop down button. This means that enter would NOT toggle the menu open and closed because first enter would open menu and next enter would activate the item with focus. I can live with that behavior we just need to document it. Should space toggle the menu? I wonder if it would be confusing to have different behavior for enter and space. Right now, menu item is only activated by enter key.

comment:9 Changed 12 years ago by simonjb

Currently, menu items are activated by both enter and space.

comment:10 Changed 12 years ago by davidb

Status: reopenednew

comment:11 Changed 12 years ago by davidb

Status: newassigned

comment:12 Changed 12 years ago by Becky Gibson

Resolution: invalid
Status: assignedclosed

Closing this invalid since enter and space will not toggle the menu due to the behavior of the menu of setting focus to the first item. Created ticket #3303 to track this as a possible usability issue.

Note: See TracTickets for help on using tickets.